#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^var([^~]*?)(function|begin)"
Local $sString = "var" & @CRLF & _
"Variavel1 : string;" & @CRLF & _
"Variavel2, Variavel3: integer;" & @CRLF & _
"Variavel4," & @CRLF & _
"Variavel5 : THandle;" & @CRLF & _
"" & @CRLF & _
"function Soma(a, b: integer): integer;" & @CRLF & _
"var" & @CRLF & _
" Varivel1: integer;" & @CRLF & _
" Variavel2, Variavel3: integer;" & @CRLF & _
"begin" & @CRLF & _
" //..." & @CRLF & _
"end;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")