import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^var([^~]*?)(function|begin)";
final String string = "var\n"
+ "Variavel1 : string;\n"
+ "Variavel2, Variavel3: integer;\n"
+ "Variavel4,\n"
+ "Variavel5 : THandle;\n\n"
+ "function Soma(a, b: integer): integer;\n"
+ "var\n"
+ " Varivel1: integer;\n"
+ " Variavel2, Variavel3: integer;\n"
+ "begin\n"
+ " //...\n"
+ "end;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}