// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^var([^~]*?)(function|begin)").unwrap();
let string = "var
Variavel1 : string;
Variavel2, Variavel3: integer;
Variavel4,
Variavel5 : THandle;
function Soma(a, b: integer): integer;
var
Varivel1: integer;
Variavel2, Variavel3: integer;
begin
//...
end;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}