import re
regex = re.compile(r"^var([^~]*?)(function|begin)", flags=re.MULTILINE)
test_str = ("var\n"
"Variavel1 : string;\n"
"Variavel2, Variavel3: integer;\n"
"Variavel4,\n"
"Variavel5 : THandle;\n\n"
"function Soma(a, b: integer): integer;\n"
"var\n"
" Varivel1: integer;\n"
" Variavel2, Variavel3: integer;\n"
"begin\n"
" //...\n"
"end;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")