using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^var([^~]*?)(function|begin)";
string input = @"var
Variavel1 : string;
Variavel2, Variavel3: integer;
Variavel4,
Variavel5 : THandle;
function Soma(a, b: integer): integer;
var
Varivel1: integer;
Variavel2, Variavel3: integer;
begin
//...
end;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}