package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^var([^~]*?)(function|begin)`)
var str = `var
Variavel1 : string;
Variavel2, Variavel3: integer;
Variavel4,
Variavel5 : THandle;
function Soma(a, b: integer): integer;
var
Varivel1: integer;
Variavel2, Variavel3: integer;
begin
//...
end;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}