re = /^var([^~]*?)(function|begin)/m
str = 'var
Variavel1 : string;
Variavel2, Variavel3: integer;
Variavel4,
Variavel5 : THandle;
function Soma(a, b: integer): integer;
var
Varivel1: integer;
Variavel2, Variavel3: integer;
begin
//...
end;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end