#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<p class="outline"><outline><\/p>)(.*)(<p class="outline-end"><outline-end><\/p>)"
Local $sString = "<p class="outline"><outline></p>" & @CRLF & _
"<p class="list">Chapter Outline</p>" & @CRLF & _
"<p class="txt">General Aspects of Gingival Epithelium Biology</p>" & @CRLF & _
"<p class="list"><list></p>" & @CRLF & _
"<p class="txt">Development of Gingival Sulcus</p>" & @CRLF & _
"<p class="list-end"><list-end></p>" & @CRLF & _
"<p class="txt">Cuticular Structures on the Tooth</p>" & @CRLF & _
"<p class="list"><list></p>" & @CRLF & _
"<p class="txt">Gingival Fluid (Sulcular Fluid)</p>" & @CRLF & _
"<p class="txt">Oral (Outer) Epithelium</p>" & @CRLF & _
"<p class="list-end"><list-end></p>" & @CRLF & _
"<p class="txt">Clinical Features</p>" & @CRLF & _
"<p class="txt">Marginal Gingiva</p>" & @CRLF & _
"<p class="txt">Interdental Gingiva</p>" & @CRLF & _
"<p class="txt">Conclusion</p>" & @CRLF & _
"<p class="list-end"><list-end></p>" & @CRLF & _
"<p class="outline-end"><outline-end></p>" & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")