const regex = /(<p class="outline"><outline><\/p>)(.*)(<p class="outline-end"><outline-end><\/p>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p class="outline"><outline><\\\/p>)(.*)(<p class="outline-end"><outline-end><\\\/p>)', 's')
const str = `<p class="outline"><outline></p>
<p class="list">Chapter Outline</p>
<p class="txt">General Aspects of Gingival Epithelium Biology</p>
<p class="list"><list></p>
<p class="txt">Development of Gingival Sulcus</p>
<p class="list-end"><list-end></p>
<p class="txt">Cuticular Structures on the Tooth</p>
<p class="list"><list></p>
<p class="txt">Gingival Fluid (Sulcular Fluid)</p>
<p class="txt">Oral (Outer) Epithelium</p>
<p class="list-end"><list-end></p>
<p class="txt">Clinical Features</p>
<p class="txt">Marginal Gingiva</p>
<p class="txt">Interdental Gingiva</p>
<p class="txt">Conclusion</p>
<p class="list-end"><list-end></p>
<p class="outline-end"><outline-end></p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}