// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)(<p class="outline"><outline><\/p>)(.*)(<p class="outline-end"><outline-end><\/p>)"#).unwrap();
let string = "<p class=\"outline\"><outline></p>
<p class=\"list\">Chapter Outline</p>
<p class=\"txt\">General Aspects of Gingival Epithelium Biology</p>
<p class=\"list\"><list></p>
<p class=\"txt\">Development of Gingival Sulcus</p>
<p class=\"list-end\"><list-end></p>
<p class=\"txt\">Cuticular Structures on the Tooth</p>
<p class=\"list\"><list></p>
<p class=\"txt\">Gingival Fluid (Sulcular Fluid)</p>
<p class=\"txt\">Oral (Outer) Epithelium</p>
<p class=\"list-end\"><list-end></p>
<p class=\"txt\">Clinical Features</p>
<p class=\"txt\">Marginal Gingiva</p>
<p class=\"txt\">Interdental Gingiva</p>
<p class=\"txt\">Conclusion</p>
<p class=\"list-end\"><list-end></p>
<p class=\"outline-end\"><outline-end></p>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}