using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p class=""outline""><outline><\/p>)(.*)(<p class=""outline-end""><outline-end><\/p>)";
string input = @"<p class=""outline""><outline></p>
<p class=""list"">Chapter Outline</p>
<p class=""txt"">General Aspects of Gingival Epithelium Biology</p>
<p class=""list""><list></p>
<p class=""txt"">Development of Gingival Sulcus</p>
<p class=""list-end""><list-end></p>
<p class=""txt"">Cuticular Structures on the Tooth</p>
<p class=""list""><list></p>
<p class=""txt"">Gingival Fluid (Sulcular Fluid)</p>
<p class=""txt"">Oral (Outer) Epithelium</p>
<p class=""list-end""><list-end></p>
<p class=""txt"">Clinical Features</p>
<p class=""txt"">Marginal Gingiva</p>
<p class=""txt"">Interdental Gingiva</p>
<p class=""txt"">Conclusion</p>
<p class=""list-end""><list-end></p>
<p class=""outline-end""><outline-end></p>
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}