use strict;
my $str = '<p class="outline"><outline></p>
<p class="list">Chapter Outline</p>
<p class="txt">General Aspects of Gingival Epithelium Biology</p>
<p class="list"><list></p>
<p class="txt">Development of Gingival Sulcus</p>
<p class="list-end"><list-end></p>
<p class="txt">Cuticular Structures on the Tooth</p>
<p class="list"><list></p>
<p class="txt">Gingival Fluid (Sulcular Fluid)</p>
<p class="txt">Oral (Outer) Epithelium</p>
<p class="list-end"><list-end></p>
<p class="txt">Clinical Features</p>
<p class="txt">Marginal Gingiva</p>
<p class="txt">Interdental Gingiva</p>
<p class="txt">Conclusion</p>
<p class="list-end"><list-end></p>
<p class="outline-end"><outline-end></p>
';
my $regex = qr/(<p class="outline"><outline><\/p>)(.*)(<p class="outline-end"><outline-end><\/p>)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}