package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<p class="outline"><outline><\/p>)(.*)(<p class="outline-end"><outline-end><\/p>)`)
var str = `<p class="outline"><outline></p>
<p class="list">Chapter Outline</p>
<p class="txt">General Aspects of Gingival Epithelium Biology</p>
<p class="list"><list></p>
<p class="txt">Development of Gingival Sulcus</p>
<p class="list-end"><list-end></p>
<p class="txt">Cuticular Structures on the Tooth</p>
<p class="list"><list></p>
<p class="txt">Gingival Fluid (Sulcular Fluid)</p>
<p class="txt">Oral (Outer) Epithelium</p>
<p class="list-end"><list-end></p>
<p class="txt">Clinical Features</p>
<p class="txt">Marginal Gingiva</p>
<p class="txt">Interdental Gingiva</p>
<p class="txt">Conclusion</p>
<p class="list-end"><list-end></p>
<p class="outline-end"><outline-end></p>
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}