import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p class=\"outline\"><outline><\\/p>)(.*)(<p class=\"outline-end\"><outline-end><\\/p>)";
final String string = "<p class=\"outline\"><outline></p>\n"
+ "<p class=\"list\">Chapter Outline</p>\n"
+ "<p class=\"txt\">General Aspects of Gingival Epithelium Biology</p>\n"
+ "<p class=\"list\"><list></p>\n"
+ "<p class=\"txt\">Development of Gingival Sulcus</p>\n"
+ "<p class=\"list-end\"><list-end></p>\n"
+ "<p class=\"txt\">Cuticular Structures on the Tooth</p>\n"
+ "<p class=\"list\"><list></p>\n"
+ "<p class=\"txt\">Gingival Fluid (Sulcular Fluid)</p>\n"
+ "<p class=\"txt\">Oral (Outer) Epithelium</p>\n"
+ "<p class=\"list-end\"><list-end></p>\n"
+ "<p class=\"txt\">Clinical Features</p>\n"
+ "<p class=\"txt\">Marginal Gingiva</p>\n"
+ "<p class=\"txt\">Interdental Gingiva</p>\n"
+ "<p class=\"txt\">Conclusion</p>\n"
+ "<p class=\"list-end\"><list-end></p>\n"
+ "<p class=\"outline-end\"><outline-end></p>\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}