# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?= \d) /$1/g;t' <<< "разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст"