using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?= \d) ";
string substitution = @"$1";
string input = @"разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}