$re = '/(\d)(?= \d) /';
$str = 'разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;