const regex = /(\d)(?= \d) /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?= \\d) ', 'g')
const str = `разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);