#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d)(?= \d) "
Local $sString = "разный текст 10 000 разный текст" & @CRLF & _
"разный текст 15 500 разный текст" & @CRLF & _
"разный текст 200 000 разный текст"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)