use strict;
my $str = 'разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст';
my $regex = qr/(\d)(?= \d) /p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";