import Foundation
let pattern = #"(\d)(?= \d) "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
разный текст 10 000 разный текст
разный текст 15 500 разный текст
разный текст 200 000 разный текст
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)