#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<div class='troll'>(?!<badTag\/>).*<\/div>)"
Local $sString = "<div class='troll'><badTag/>trololoQWE</div>" & @CRLF & _
"" & @CRLF & _
"<div class='troll'>sometexthere<badTag/>trololoQWE</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div class='troll'><badTags/>trololoQWE</div>" & @CRLF & _
"" & @CRLF & _
"<div class='troll'><goodTag/>trololoQWE</div>" & @CRLF & _
"" & @CRLF & _
"<div class='troll'>trololoQWE</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")