re = /(<div class='troll'>(?!<badTag\/>).*<\/div>)/
str = '<div class=\'troll\'><badTag/>trololoQWE</div>
<div class=\'troll\'>sometexthere<badTag/>trololoQWE</div>
<div class=\'troll\'><badTags/>trololoQWE</div>
<div class=\'troll\'><goodTag/>trololoQWE</div>
<div class=\'troll\'>trololoQWE</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end