using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div class='troll'>(?!<badTag\/>).*<\/div>)";
string input = @"<div class='troll'><badTag/>trololoQWE</div>
<div class='troll'>sometexthere<badTag/>trololoQWE</div>
<div class='troll'><badTags/>trololoQWE</div>
<div class='troll'><goodTag/>trololoQWE</div>
<div class='troll'>trololoQWE</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}