use strict;
my $str = '<div class=\'troll\'><badTag/>trololoQWE</div>
<div class=\'troll\'>sometexthere<badTag/>trololoQWE</div>
<div class=\'troll\'><badTags/>trololoQWE</div>
<div class=\'troll\'><goodTag/>trololoQWE</div>
<div class=\'troll\'>trololoQWE</div>';
my $regex = qr/(<div class='troll'>(?!<badTag\/>).*<\/div>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}