$re = '/(<div class=\'troll\'>(?!<badTag\/>).*<\/div>)/';
$str = '<div class=\'troll\'><badTag/>trololoQWE</div>
<div class=\'troll\'>sometexthere<badTag/>trololoQWE</div>
<div class=\'troll\'><badTags/>trololoQWE</div>
<div class=\'troll\'><goodTag/>trololoQWE</div>
<div class=\'troll\'>trololoQWE</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);