import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<div class='troll'>(?!<badTag\\/>).*<\\/div>)";
final String string = "<div class='troll'><badTag/>trololoQWE</div>\n\n"
+ "<div class='troll'>sometexthere<badTag/>trololoQWE</div>\n\n\n"
+ "<div class='troll'><badTags/>trololoQWE</div>\n\n"
+ "<div class='troll'><goodTag/>trololoQWE</div>\n\n"
+ "<div class='troll'>trololoQWE</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}