const regex = /(<div class='troll'>(?!<badTag\/>).*<\/div>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<div class=\'troll\'>(?!<badTag\\\/>).*<\\\/div>)', 'g')
const str = `<div class='troll'><badTag/>trololoQWE</div>
<div class='troll'>sometexthere<badTag/>trololoQWE</div>
<div class='troll'><badTags/>trololoQWE</div>
<div class='troll'><goodTag/>trololoQWE</div>
<div class='troll'>trololoQWE</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}