using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b)[,.'-:""]+(?=\s|$)|""";
string input = @"I've found the regex to locate all hyphenated and ""apostrophied"" words:
Examples: l'Equipe and action-oriented
I'm not sure how to utilize this information to get what I want after a bit of searching...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}