#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)<cfmail" & @CRLF & _
"(?:" & @CRLF & _
" \s+to="(?<to>[^"]+)"" & @CRLF & _
" |" & @CRLF & _
" \s+from="(?<from>[^"]+)"" & @CRLF & _
" |" & @CRLF & _
" \s+subject="(?<subject>[^"]+)"" & @CRLF & _
" |" & @CRLF & _
" \s+type="(?<type>[^"]+)"" & @CRLF & _
")+" & @CRLF & _
">" & @CRLF & _
".*?<\/cfmail>"
Local $sString = "<cfmail to="#toAddr#" from="#fromAddress#" " & @CRLF & _
" subject="#subject#" type="html">" & @CRLF & _
" #emailMsg#" & @CRLF & _
"</cfmail>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")