re = /<cfmail
(?:
\s+to="(?<to>[^"]+)"
|
\s+from="(?<from>[^"]+)"
|
\s+subject="(?<subject>[^"]+)"
|
\s+type="(?<type>[^"]+)"
)+
>
.*?<\/cfmail>/x
str = '<cfmail to="#toAddr#" from="#fromAddress#"
subject="#subject#" type="html">
#emailMsg#
</cfmail>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end