package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<cfmail
(?:
\s+to="(?<to>[^"]+)"
|
\s+from="(?<from>[^"]+)"
|
\s+subject="(?<subject>[^"]+)"
|
\s+type="(?<type>[^"]+)"
)+
>
.*?<\/cfmail>`)
var str = `<cfmail to="#toAddr#" from="#fromAddress#"
subject="#subject#" type="html">
#emailMsg#
</cfmail>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}