import re
regex = re.compile(r"""
<cfmail
(?:
\s+to="(?<to>[^"]+)"
|
\s+from="(?<from>[^"]+)"
|
\s+subject="(?<subject>[^"]+)"
|
\s+type="(?<type>[^"]+)"
)+
>
.*?<\/cfmail>
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("<cfmail to=\"#toAddr#\" from=\"#fromAddress#\" \n"
" subject=\"#subject#\" type=\"html\">\n"
" #emailMsg#\n"
"</cfmail>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")