#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]"
Local $sString = "vuser_init.c(48): Notify: Transaction "UC_13_StartPage" ended with a "Pass" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")