const regex = /(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<action>.+)\\((?<line_number>\\d+)\\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \\(Duration: (?<duration>[\\d\\.]+) Wasted Time: (?<wasted_time>[\\d\\.]+)\\). \\[MsgId: (?<msg_id>.+)\\]', '')
const str = `vuser_init.c(48): Notify: Transaction "UC_13_StartPage" ended with a "Pass" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}