using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction ""(?<transaction_name>.+)"" ended with a ""(?<transaction_status>.+)"" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]";
string input = @"vuser_init.c(48): Notify: Transaction ""UC_13_StartPage"" ended with a ""Pass"" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}