import re
regex = re.compile(r"(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction \"(?<transaction_name>.+)\" ended with a \"(?<transaction_status>.+)\" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]")
test_str = "vuser_init.c(48): Notify: Transaction \"UC_13_StartPage\" ended with a \"Pass\" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")