// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]"#).unwrap();
let string = "vuser_init.c(48): Notify: Transaction \"UC_13_StartPage\" ended with a \"Pass\" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}