package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]`)
var str = `vuser_init.c(48): Notify: Transaction "UC_13_StartPage" ended with a "Pass" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}