#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?"
Local $sString = "auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200" & @CRLF & _
"auth required pam_faillock.so authsucc even_deny_root unlock_time=1200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")