using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?";
string input = @"auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200
auth required pam_faillock.so authsucc even_deny_root unlock_time=1200";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}