const regex = /^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^auth\\s+required\\s+pam_faillock\\.so\\s(?|.*?(deny=(\\d*))|()())?', 'gm')
const str = `auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200
auth required pam_faillock.so authsucc even_deny_root unlock_time=1200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}