import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^auth\\s+required\\s+pam_faillock\\.so\\s(?|.*?(deny=(\\d*))|()())?";
final String string = "auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200\n"
+ "auth required pam_faillock.so authsucc even_deny_root unlock_time=1200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}