// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?").unwrap();
let string = "auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200
auth required pam_faillock.so authsucc even_deny_root unlock_time=1200";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}