re = /^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?/m
str = 'auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200
auth required pam_faillock.so authsucc even_deny_root unlock_time=1200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end