#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$"
Local $sString = "09:00-10:00,12:00-14:30,16:00-18:00" & @CRLF & _
"09:00-10:00,12:00-14:30," & @CRLF & _
"09:00-10:00" & @CRLF & _
"09:00-10:00," & @CRLF & _
"09:00" & @CRLF & _
"09:00-10:00-12:00-14:30,16:00-18:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")