import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d{2}:\\d{2}\\-\\d{2}:\\d{2})(?:,(?!$))?)*$";
final String string = "09:00-10:00,12:00-14:30,16:00-18:00\n"
+ "09:00-10:00,12:00-14:30,\n"
+ "09:00-10:00\n"
+ "09:00-10:00,\n"
+ "09:00\n"
+ "09:00-10:00-12:00-14:30,16:00-18:00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}