import Foundation
let pattern = #"^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
09:00-10:00,12:00-14:30,16:00-18:00
09:00-10:00,12:00-14:30,
09:00-10:00
09:00-10:00,
09:00
09:00-10:00-12:00-14:30,16:00-18:00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)