const regex = /^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d{2}:\\d{2}\\-\\d{2}:\\d{2})(?:,(?!$))?)*$', 'gm')
const str = `09:00-10:00,12:00-14:30,16:00-18:00
09:00-10:00,12:00-14:30,
09:00-10:00
09:00-10:00,
09:00
09:00-10:00-12:00-14:30,16:00-18:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}