using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$";
string input = @"09:00-10:00,12:00-14:30,16:00-18:00
09:00-10:00,12:00-14:30,
09:00-10:00
09:00-10:00,
09:00
09:00-10:00-12:00-14:30,16:00-18:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}